const regex = /(foo[^\s]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(foo[^\\s]*)', 'gm')
const str = `hello foobar world`;
const subst = `<mark>$1</mark>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);