import re
regex = re.compile(r"(foo[^\s]*)", flags=re.MULTILINE)
test_str = "hello foobar world"
subst = "<mark>$1</mark>"
result = regex.sub(subst, test_str)
if result:
print(result)