using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\""type\"":\""device\"",\""key\"":\""Source device\"",\""values\"":\[{\""ip\"":\""(?<ip>\d+\.\d+\.\d+\.\d+)\"",\""mac\""";
string input = @"{""type"":""device"",""key"":""Source device"",""values"":[{""ip"":""10.10.10.10"",""mac""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}