package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{\"type\":\"device\",\"key\":\"Source device\",\"values\":\[{\"ip\":\"(?<ip>\d+\.\d+\.\d+\.\d+)\",\"mac\"`)
var str = `{"type":"device","key":"Source device","values":[{"ip":"10.10.10.10","mac"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}