re = /\{\"type\":\"device\",\"key\":\"Source device\",\"values\":\[{\"ip\":\"(?<ip>\d+\.\d+\.\d+\.\d+)\",\"mac\"/m
str = '{"type":"device","key":"Source device","values":[{"ip":"10.10.10.10","mac"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end