import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\\"type\\\":\\\"device\\\",\\\"key\\\":\\\"Source device\\\",\\\"values\\\":\\[\\{\\\"ip\\\":\\\"(?<ip>\\d+\\.\\d+\\.\\d+\\.\\d+)\\\",\\\"mac\\\"";
final String string = "{\"type\":\"device\",\"key\":\"Source device\",\"values\":[{\"ip\":\"10.10.10.10\",\"mac\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}