use strict;
my $str = '"emailDomains":["google.co.uk","google.com","google.com","google.com","google.co.uk"]';
my $regex = qr/" *, *"/mp;
my $subst = ', ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";