package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\+971|00971|0)?(?:50|51|52|55|56|2|3|4|6|7|9)\d{7}$`)
var str = `00971551234567
+971551234567
+97141234567
0551234567
041234567
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}