re = /^(?:\+971|00971|0)?(?:50|51|52|55|56|2|3|4|6|7|9)\d{7}$/m
str = '00971551234567
+971551234567
+97141234567
0551234567
041234567
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result