const regex = /^(?:\+971|00971|0)?(?:50|51|52|55|56|2|3|4|6|7|9)\d{7}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\+971|00971|0)?(?:50|51|52|55|56|2|3|4|6|7|9)\\d{7}$', 'gm')
const str = `00971551234567
+971551234567
+97141234567
0551234567
041234567
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);