use strict;
my $str = '00971551234567
+971551234567
+97141234567
0551234567
041234567
';
my $regex = qr/^(?:\+971|00971|0)?(?:50|51|52|55|56|2|3|4|6|7|9)\d{7}$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";