#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(ประเทศ)|(อเมริกา|เกาหลีใต้|เกาหลีเหนือ|ฝรั่งเศส|อิตาลี)|ประเทศ.*"
Local $sString = "ประเทศอเมริกาเป็นประเทศที่ดี" & @CRLF & _
"ประเทศเกาหลีใต้เป็นประเทศที่ดี" & @CRLF & _
"เกาหลีใต้คือประเทศ" & @CRLF & _
"ประเทศเกาหลีเหนือคือประเทศสวยงาม" & @CRLF & _
"ประเทศญี่ปุ่น" & @CRLF & _
"ประเทศอเมรกาเป็นประเทศที่ดี" & @CRLF & _
"เมืองที่สวยงามคือประเทศที่ดีงามอย่างฝรั่งเศสแต่ก็ไม่ได้มากไปกว่าอิตาลีที่เป็นประเทศประเทศหนึ่งเหมือนกัน" & @CRLF & _
"ประเทศรักสงบ"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")