#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[^[:alpha:]\n]*[[:alpha:]])(?=[[:alpha:]]*[^[:alpha:]\n])\S*$"
Local $sString = "AWfrer546" & @CRLF & _
"ASdew34254%$" & @CRLF & _
"" & @CRLF & _
"AS dew 342 54%$" & @CRLF & _
"EQWRERrewr" & @CRLF & _
"rrerer"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")