$re = '/^(?=[^[:alpha:]\n]*[[:alpha:]])(?=[[:alpha:]]*[^[:alpha:]\n])\S*$/m';
$str = 'AWfrer546
ASdew34254%$
AS dew 342 54%$
EQWRERrewr
rrerer';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);