import re
regex = re.compile(r"^(?=[^[:alpha:]\n]*[[:alpha:]])(?=[[:alpha:]]*[^[:alpha:]\n])\S*$", flags=re.MULTILINE)
test_str = ("AWfrer546\n"
"ASdew34254%$\n\n"
"AS dew 342 54%$\n"
"EQWRERrewr\n"
"rrerer")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")