#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*-.*(?P<sig>[a-zA-Z]{2})"
Local $sString = "VIP MANAUS, Endereço: R. VISCONDE DE SINIMBU, 1568, Bairro: PQ. LARANJEIRAS, Manaus - AM" & @CRLF & _
"" & @CRLF & _
"VIP PORTO VELHO, Endereço: AV. RIO MADEIRA Nº 612, Bairro: LAGOA, PORTO VELHO -RO" & @CRLF & _
"" & @CRLF & _
"VIP BELÉM ALÇA VIARIA, Endereço: KM 01, Bairro: CENTRO, Marituba-pa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")