re = /.*-.*(?P<sig>[a-zA-Z]{2})/m
str = 'VIP MANAUS, Endereço: R. VISCONDE DE SINIMBU, 1568, Bairro: PQ. LARANJEIRAS, Manaus - AM
VIP PORTO VELHO, Endereço: AV. RIO MADEIRA Nº 612, Bairro: LAGOA, PORTO VELHO -RO
VIP BELÉM ALÇA VIARIA, Endereço: KM 01, Bairro: CENTRO, Marituba-pa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end