const regex = new RegExp('.*-.*(?P<sig>[a-zA-Z]{2})', 'gm')
const str = `VIP MANAUS, Endereço: R. VISCONDE DE SINIMBU, 1568, Bairro: PQ. LARANJEIRAS, Manaus - AM
VIP PORTO VELHO, Endereço: AV. RIO MADEIRA Nº 612, Bairro: LAGOA, PORTO VELHO -RO
VIP BELÉM ALÇA VIARIA, Endereço: KM 01, Bairro: CENTRO, Marituba-pa`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}