import Foundation
let pattern = #".*-.*(?P<sig>[a-zA-Z]{2})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
VIP MANAUS, Endereço: R. VISCONDE DE SINIMBU, 1568, Bairro: PQ. LARANJEIRAS, Manaus - AM
VIP PORTO VELHO, Endereço: AV. RIO MADEIRA Nº 612, Bairro: LAGOA, PORTO VELHO -RO
VIP BELÉM ALÇA VIARIA, Endereço: KM 01, Bairro: CENTRO, Marituba-pa
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)