using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((00|\+)39[. ]??)??3\d{2}[. ]??\d{6,7}$";
string input = @"+393339910203";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}