const regex = /^((00|\+)39[. ]??)??3\d{2}[. ]??\d{6,7}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((00|\\+)39[. ]??)??3\\d{2}[. ]??\\d{6,7}$', '')
const str = `+393339910203`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}