$re = '/^((00|\+)39[. ]??)??3\d{2}[. ]??\d{6,7}$/';
$str = '+393339910203';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);