package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((00|\+)39[. ]??)??3\d{2}[. ]??\d{6,7}$`)
var str = `+393339910203`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}