using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" style='[^']*'";
string input = @"let myString= ""<div style='color: red;'>Hello world</div><p>Some text here</p><div style='border: 0px;'>hello world 2!</div>"";
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}