$re = '/ style=\'[^\']*\'/';
$str = 'let myString= "<div style=\'color: red;\'>Hello world</div><p>Some text here</p><div style=\'border: 0px;\'>hello world 2!</div>";
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);