package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(` style='[^']*'`)
var str = `let myString= "<div style='color: red;'>Hello world</div><p>Some text here</p><div style='border: 0px;'>hello world 2!</div>";
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}