re = / style='[^']*'/
str = 'let myString= "<div style=\'color: red;\'>Hello world</div><p>Some text here</p><div style=\'border: 0px;\'>hello world 2!</div>";
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end