import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2}))|(([0-9]{2,3}[:-]){5}([0-9]{2,3})))";
final String string = "123-201-12-01-125-212";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}