// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2}))|(([0-9]{2,3}[:-]){5}([0-9]{2,3})))").unwrap();
let string = "123-201-12-01-125-212";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}