# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^= Fields!(\w+)\.Value & Fields!(\w+)\.Value$/$1 && $2/gm;t' <<< "= Fields!Change_Date.Value & Fields!Change_User.Value"