using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^= Fields!(\w+)\.Value & Fields!(\w+)\.Value$";
string substitution = @"$1 && $2";
string input = @"= Fields!Change_Date.Value & Fields!Change_User.Value";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}