#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^= Fields!(\w+)\.Value & Fields!(\w+)\.Value$"
Local $sString = "= Fields!Change_Date.Value & Fields!Change_User.Value"
Local $sSubst = "$1 && $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)