re = /^= Fields!(\w+)\.Value & Fields!(\w+)\.Value$/m
str = '= Fields!Change_Date.Value & Fields!Change_User.Value'
subst = '$1 && $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result