#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^value=(/(path1|path2)|\$VAR|\${VAR})/?$"
Local $sString = "value=/path1" & @CRLF & _
"value=/path2" & @CRLF & _
"value=/path1/" & @CRLF & _
"value=/path2/" & @CRLF & _
"value=${VAR}" & @CRLF & _
"value=${VAR}/" & @CRLF & _
"value=$VAR" & @CRLF & _
"value=$VAR/" & @CRLF & _
"value=/path1/foo" & @CRLF & _
"value=/path2/foo" & @CRLF & _
"value=${VAR}/foo" & @CRLF & _
"value=$VAR/foo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")