// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^value=(/(path1|path2)|\$VAR|\${VAR})/?$").unwrap();
let string = "value=/path1
value=/path2
value=/path1/
value=/path2/
value=${VAR}
value=${VAR}/
value=$VAR
value=$VAR/
value=/path1/foo
value=/path2/foo
value=${VAR}/foo
value=$VAR/foo";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}