import Foundation
let pattern = #"^value=(/(path1|path2)|\$VAR|\${VAR})/?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
value=/path1
value=/path2
value=/path1/
value=/path2/
value=${VAR}
value=${VAR}/
value=$VAR
value=$VAR/
value=/path1/foo
value=/path2/foo
value=${VAR}/foo
value=$VAR/foo
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)