$re = '@^value=(/(path1|path2)|\$VAR|\${VAR})/?$@m';
$str = 'value=/path1
value=/path2
value=/path1/
value=/path2/
value=${VAR}
value=${VAR}/
value=$VAR
value=$VAR/
value=/path1/foo
value=/path2/foo
value=${VAR}/foo
value=$VAR/foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);