#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\(\(\(?([^}]*?)\)\)\)"
Local $sString = "((Short Title (in Navigation & Breadcrumb))) Pflanzen & Samen" & @CRLF & _
"((Post-Text)) Hast du unser Osterschoggi-Sortiment schon probiert? ((Schleckmaul))" & @CRLF & _
"[Ceci est un ((non visible)) (test)]" & @CRLF & _
"[[Ceci est un ((non visible)) (test)]]" & @CRLF & _
"Ceci est un [[visible ((non visible))]] (test)" & @CRLF & _
"Ceci est un ((non visible [non visible])) (test)" & @CRLF & _
"((Headline))" & @CRLF & _
"((non visible)) " & @CRLF & _
"Ceci doit être traduit" & @CRLF & _
"((Sternchentext))" & @CRLF & _
"*Mit Cashback Fr. 39.90, Rückvergütung (Überweisung) einlösbar unter canon.ch/summer, gültig von 15.2. bis 15.5.2021 ((maximal 140 Zeichen inkl. Leerzeichen))" & @CRLF & _
"Lieferung per Paketkurier (Direktlieferung (normal))" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")