import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(\\(\\(?([^\\}]*?)\\)\\)\\)";
final String string = "((Short Title (in Navigation & Breadcrumb))) Pflanzen & Samen\n"
+ "((Post-Text)) Hast du unser Osterschoggi-Sortiment schon probiert? ((Schleckmaul))\n"
+ "[Ceci est un ((non visible)) (test)]\n"
+ "[[Ceci est un ((non visible)) (test)]]\n"
+ "Ceci est un [[visible ((non visible))]] (test)\n"
+ "Ceci est un ((non visible [non visible])) (test)\n"
+ "((Headline))\n"
+ "((non visible)) \n"
+ "Ceci doit être traduit\n"
+ "((Sternchentext))\n"
+ "*Mit Cashback Fr. 39.90, Rückvergütung (Überweisung) einlösbar unter canon.ch/summer, gültig von 15.2. bis 15.5.2021 ((maximal 140 Zeichen inkl. Leerzeichen))\n"
+ "Lieferung per Paketkurier (Direktlieferung (normal))\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}