re = /\(\(\(?([^}]*?)\)\)\)/m
str = '((Short Title (in Navigation & Breadcrumb))) Pflanzen & Samen
((Post-Text)) Hast du unser Osterschoggi-Sortiment schon probiert? ((Schleckmaul))
[Ceci est un ((non visible)) (test)]
[[Ceci est un ((non visible)) (test)]]
Ceci est un [[visible ((non visible))]] (test)
Ceci est un ((non visible [non visible])) (test)
((Headline))
((non visible))
Ceci doit être traduit
((Sternchentext))
*Mit Cashback Fr. 39.90, Rückvergütung (Überweisung) einlösbar unter canon.ch/summer, gültig von 15.2. bis 15.5.2021 ((maximal 140 Zeichen inkl. Leerzeichen))
Lieferung per Paketkurier (Direktlieferung (normal))
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end