# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(?:(?:<([^ ]+)(?:.*)>)\[\[(?:<\\/\1>))|(?:\[\[))(?:(?:(?:<([^ ]+)(?:.*)>)(.+?)(?:<\\/\2>))|(.+?))(?:(?:(?:<([^ ]+)(?:.*)>)\]\](?:<\\/\5>))|(?:\]\]))/$3$4/gm;t' <<< "[[plain wikilinks]]
<e>[[</e>first tag]]
<e dsss>[[</e>meta on first tag]]
<e dsss>[[</e><div>first tag + meta + container</div>]]
<e dsss>[[</e><div>first tag + meta + container + third tag</div><div>]]</div>
<e dsss>[[</e>forgot a bracket
<e dsss>[[</e>bracket containers<e>]]</e>
all is well"