using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"(?:(?:(?:<([^ ]+)(?:.*)>)\[\[(?:<\/\1>))|(?:\[\[))(?:(?:(?:<([^ ]+)(?:.*)>)(.+?)(?:<\/\2>))|(.+?))(?:(?:(?:<([^ ]+)(?:.*)>)\]\](?:<\/\5>))|(?:\]\]))";
        string substitution = @"$3$4";
        string input = @"[[plain wikilinks]]
<e>[[</e>first tag]]
<e dsss>[[</e>meta on first tag]]
<e dsss>[[</e><div>first tag + meta + container</div>]]
<e dsss>[[</e><div>first tag + meta + container + third tag</div><div>]]</div>
<e dsss>[[</e>forgot a bracket
<e dsss>[[</e>bracket containers<e>]]</e>
all is well";
        RegexOptions options = RegexOptions.Multiline;
        
        Regex regex = new Regex(pattern, options);
        string result = regex.Replace(input, substitution);
    }
}