import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:(?:<([^ ]+)(?:.*)>)\\[\\[(?:<\\/\\1>))|(?:\\[\\[))(?:(?:(?:<([^ ]+)(?:.*)>)(.+?)(?:<\\/\\2>))|(.+?))(?:(?:(?:<([^ ]+)(?:.*)>)\\]\\](?:<\\/\\5>))|(?:\\]\\]))";
final String string = "[[plain wikilinks]]\n"
+ "<e>[[</e>first tag]]\n"
+ "<e dsss>[[</e>meta on first tag]]\n"
+ "<e dsss>[[</e><div>first tag + meta + container</div>]]\n"
+ "<e dsss>[[</e><div>first tag + meta + container + third tag</div><div>]]</div>\n"
+ "<e dsss>[[</e>forgot a bracket\n"
+ "<e dsss>[[</e>bracket containers<e>]]</e>\n"
+ "all is well";
final String subst = "$3$4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}