# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?:(?:<([^ ]+)(?:.*)>)\[\[(?:<\/\1>))|(?:\[\[))(?:(?:(?:<([^ ]+)(?:.*)>)(.+?)(?:<\/\2>))|(.+?))(?:(?:(?:<([^ ]+)(?:.*)>)\]\](?:<\/\5>))|(?:\]\]))"
test_str = ("[[plain wikilinks]]\n"
"<e>[[</e>first tag]]\n"
"<e dsss>[[</e>meta on first tag]]\n"
"<e dsss>[[</e><div>first tag + meta + container</div>]]\n"
"<e dsss>[[</e><div>first tag + meta + container + third tag</div><div>]]</div>\n"
"<e dsss>[[</e>forgot a bracket\n"
"<e dsss>[[</e>bracket containers<e>]]</e>\n"
"all is well")
subst = "$3$4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.