using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=want )([^ ]*)(?= !)";
string input = @"This is the number I want +2143334 !, again this is the next number I want +234343443 !, last number I want +76645 !, fininshed";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}