import Foundation
let pattern = #"(?<=want )([^ ]*)(?= !)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"This is the number I want +2143334 !, again this is the next number I want +234343443 !, last number I want +76645 !, fininshed"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)