re = /(?<=want )([^ ]*)(?= !)/
str = 'This is the number I want +2143334 !, again this is the next number I want +234343443 !, last number I want +76645 !, fininshed'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end