const regex = /(?<=want )([^ ]*)(?= !)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=want )([^ ]*)(?= !)', 'g')
const str = `This is the number I want +2143334 !, again this is the next number I want +234343443 !, last number I want +76645 !, fininshed`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}