using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([а-яa-zё0-9]){2})\.((?2){2})\.((?2){3})$";
string input = @"d1.df.dfd";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}