$re = '~^(([а-яa-zё0-9]){2})\.((?2){2})\.((?2){3})$~ui';
$str = 'd1.df.dfd';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);